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1   Introduction
Welcome to the User-friendly Internet Desktop GIS (uDig) application!

This  is  a  walkthough  of  the  installation  and  use  of  the  uDig  application,  it  covers  the  general  
introduction to the GIS and the use of shapefile.

uDig  is  collaborative  effort  brought  together  by  a  diverse  project  management  committee  from 
organizations across the world:

● Andrea Antonello (Italy)

● Frank Gasdorf (Germany)

● Jesse Eichar (Switzerland)

● Jody Garnett (Australia)

● Mauricio Pazos (Spain)

uDig was originated at Refractions Research in Canada with funding from GeoConnections Canada.

uDig is intended to be used in conjunction with your existing investment in spatial information. Data  
are the most important part of the work, uDig supports a wide range of formats, it is compatible with a 
range of spatial databases and can access of information services such as WMS and WFS.

Other features are support for printing and excellent desktop integration.

The use of  an open source license (EPL and BSD) allows the uDig project  to be used by your  
organization with no per seat license.

For more information and a selection of case studies:
This tutorial is written by UniTN, please refer to the authors for any question.
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● http://udig.refractions.net/files/tutorials/uDigCaseStudies.pdf

● http://udig.refractions.net/

2   Installing and Running The uDig Application
In this section, you will install and run the application, which will be used for viewing map information.

Windows install:

● Double-click the installer.

Note!
For this workshop you can find the uDig installer on the Desktop. In all  the other  
occasions you first have to download the installer from uDig website.

● The installer will allow you to install uDig into the directory of your choice.

● We have a number of license agreements to click through.

This tutorial is written by UniTN, please refer to the authors for any question.
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Note!
uDig  is  an  open source  project  released  with  a  business  friendly  Eclipse  Public  
License  (EPL)  and  Refractions  BSD  3  Clause  License  
(http://udig.refractions.net/files/bsd3-v10.html).

ECW/JP2 support is freely licensed for desktop application use.

● By default uDig will be installed into your Program Files directory.

● Shortcuts will be created in your start menu.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Please wait while uDig is installed.

● Congratulations you have installed uDig!

● If you are working in a corporate environment with a firewall please review the instructions on 
uDig webpage for details on proxy configuration.

This tutorial is written by UniTN, please refer to the authors for any question.
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3   Welcome
Now that everything is installed we can start up the application for the first time.

● After  completing  the  installation,  run  the  uDig  application  from  the  Windows  Start  --> 
Programs menu.

● Initially  you  are  presented  with  the  uDig  workbench.  The  uDig  workbench  consists  of  a 
number of panels called views.

● The Welcome view runs along the right hand side of the screen. This view contains:

● a link to the Getting Started tutorial from the online documentation.

● a link to the uDig Website

● To close the Welcome view click the x next to the word welcome.

This tutorial is written by UniTN, please refer to the authors for any question.
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● You can return to the welcome view at any time using the Help --> Welcome menu item.

3.1   Online Documentation and Tutorials
In this section you will open up the online help and access reference information.

Hint!

You can access the online help directly by pressing Getting Started on the welcome 
screen.

1. Open up the Help menu and select Help Contents

2. The windows firewall will need to allow the help application to startup.

3. This will bring up the online help system; the help system is a web application that makes use 
of a Contents tree to allow you to navigate between Pages.

This tutorial is written by UniTN, please refer to the authors for any question.
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4. The Contents tree organizes Pages into Books. Additional books are included as you install 
additional features.

3.2   Help Categories
You can access additional reference information in the following categories:

● Getting Started: tutorials that will help familiarize yourself using uDig.

● Concepts: High-Level description of ideas, architecture abd background knowledge.

● Tasks: step by step instructions for performing specific actions and tasks in the application.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Reference: reference for the uDig application describing wizards, views, and shortcuts.

4   The Workbench
Before we start playing with maps, let's take a look at the default layout of the uDig workbench and 
what some of the key components are.

Shown below is a typical session of uDig with an open Map editor surrounded by Projects,  Layers, 
and Catalog views. These views will be described further as we demonstrate their uses.

This tutorial is written by UniTN, please refer to the authors for any question.
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5   Working with Files
You can work directly with files from the file system.

● This section makes use of sample data provided by the Natural Earth project.

● Click on the following link (http://udig.refractions.net/files/data/data_1_3.zip) and save the zip 
file to your local computer.

○ data_1_3.zip

Hint!

Please find the data folder ready to be used on your Desktop: data_1_3.zip.

● Unzip the download to create your data directory.

○ You may wish to create a data directory on your desktop or in your documents folder.

● Create an empty Map by selecting File --> New --> New Map from the menubar. As you can 
see a new project is created in the Projects view and a new map is added into it called Map

● Drag and Drop the file 10m_land.shp onto your open Map.

The map will take the size and projection of the first layer added to it.

This tutorial is written by UniTN, please refer to the authors for any question.

http://udig.refractions.net/files/data/data_1_3.zip
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You can also see the file listed in the Catalog view in case you wish to use it on another map.

● When working  with  uDig  you  will  often  find  yourself  combining  information  from several 
different sources.

Add the 10m_ocean.shp shapefile to your map.

The application will automatically:

○ Make use of any included style layer descriptor file, or generate a default style.

○ Perform any reprojection required on the fly allowing you to view layers side by side

This tutorial is written by UniTN, please refer to the authors for any question.
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5.1   Map Editor
The Map editor is used to display a map on screen. You can open several Maps and the Layers view 
will list the contents of the currently selected editor.

● The Map editor is used to display the visible layers.

● Map interaction is controlled by the selected Tool in the Palette on the right hand side of the 
screen.

Try the navigation tools along the top of the tool Palette.

●  Zoom (keyboard short cut z) Click or drag the left button (as a window) to 

zoom in, or right button to zoom out.

●  Pan (keyboard short cut p) Click and drag to move the display.

● Several shortcuts are always available:

● Mouse Wheel: used to zoom in and out quickly

● Middle Button: Used to quickly pan the display

● The Palette organises tools into drawers according to function.

● You can open and close the drawers by clicking on their title.

● Drawers will close automatically as you switch between drawers. Although 
you can also pin a drawer open for easy access.

● Available tools change depending on the currently selected layer

● Right click on a drawer to customise the size of the icons used; and how much information is 
displayed in the Palette.

This tutorial is written by UniTN, please refer to the authors for any question.
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● The Map editor lists common commands in the toolbar along the top of the screen.

●  Extent: zoom out to show all enabled layers

●  Zoom In

●  Zoom Out

●  Stop Rendering

●  Refresh Map

● Press the  Refresh button, and watch the processing information displayed in the bottom 

right corner of the workbench.

● Description and progress bar indicate rendering status.

● Button to open the Progress view providing more detail when several layers 
are rendering at once and the ability to cancel any long running activities.

This tutorial is written by UniTN, please refer to the authors for any question.
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● The Layers view shows the order in which layers are drawn. Please select the 10m_land layer 
and use the  Move down button from the  Layer view toolbar to move selected layer to the 
bottom of the list.

Hint!

Drag and Drop You can also drag layers up and down in the layer view to change  
the order.

● The order is now changed.

● You can also use the checkboxes next to each Layer to turn them on and off: try to check the 
box near the name of 10m land layer in the Layer view and see what happens.

This tutorial is written by UniTN, please refer to the authors for any question.
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Note!
Selection an checking the layer are different operations and means different behavior  
of the tools in the GIS. Checking has only influence on visualization of the layer in  
the  Map  while  selection is  active  when  you  can  see  the  layer  with  a  the  blue  
background in the Layer view and this is the operation that activates all the tools in  
uDig: selection, edit, ...

6   Import Directly to The Catalog
As you  can  see  all  the  layers  visualized  in  the  Map and  in  the  Layer views  and  added to  the 
application using  drag and drop are also added to the  Catalog view, in this section we will  import 
content directly into the catalog.

● On the Catalog view please press the Import button on the top right of the view:

● In the wizard select Other --> Data and press Next.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Choose File from the list and press Next.

● This time we are going to import layer  10m_admin_0_countries.shp contained in the data 
folder: please select this file in the wizard.

● Press Finish to import the selected layer into the Catalog.

This tutorial is written by UniTN, please refer to the authors for any question.
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Note!
From the Catalog view you can add only one layer at the time.

Try to use an other way to import a layer directly into the Catalog:

● Inside the Catalog view please press the right click of the mouse and select the Import option 
from the menu

● Proceed as explained before and select 10m_lakes file from the data folder in the wizard.

Now that we have imported the shapefiles into the catalog we can add them to our Map.

6.1   Adding Layers from the Catalog View
Adding a Layer from a previously connected data source:

● Drag and Drop the 10m_admin_0_countries layer directly onto Map editor.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Earlier we used the the layer view to reorder using the up and down buttons, this 
time we will drag the layers into the right order.

Select the 10m_lakes layer in the layer view and drag it to the bottom of the list.

Note!
The layers of lakes is not well visible in the Map, move this layer to the top of the list  
in the Layer view.

This tutorial is written by UniTN, please refer to the authors for any question.
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● In the  Layers view select the layer  10m_admin_0_countries,  rigth click of the mouse and 
select the Delete option to remove the layer from the list and delete it from the visualization.

● Do the same for 10m_lakes: in the Layers view select the layer 10m_lakes, rigth click of the 
mouse and select the Delete option.

Hint!

Deleting an entire layer withing uDig without editing it will not delete the original file,  
just the connection in the program.

Now that we deleted the layers we will try to add them to the same Map using a different procedure:

● in the Catalog view select the layer you want to show in the Map 10m_admin_0_countries

● right-click on 10m_admin_0_countries and select Add to Current Map.

This tutorial is written by UniTN, please refer to the authors for any question.
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● The new layer  will  appear in  the  Layers view and automatically  start  to  render.  When it 
finishes rendering, you should see a new 10m_admin_0_countries layer drawn on screen.

● The catalog also comes equipped with a built in service called Decoration. Select Decoration 
--> Scalebar in the Catalog view and drag this layer onto the Map

This tutorial is written by UniTN, please refer to the authors for any question.
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● You can add multiple layers directly to the Map selecting from the main menu Layer --> Add

● Select the desired layers. In this case it is possible to add multiple layers together.

This tutorial is written by UniTN, please refer to the authors for any question.



uDig Tutorial p. 22

7   Style Editor
The  Style  Editor allows  fine grain  control  of  the  layer  rendering.  In  addition to  shapes,  layers 
contain attribute values which we can use to control the rendering process.

In this section we will create a  Styled Layer Descriptor (SLD) with the uDig Style Editor in order to 
generate labels and theme by attribute values.

Note!
if you create the SLD file for the shapefile you will maintain the same style for the  
layer for ever, so if you exchange the data, others will see the data same as you and  
if you load the data in an other Map you will see them always the same style.  To 
export  the current  style click  on the  Export icon  One click  style export for file  
based layers.

● Create a new map using File --> New --> New Map

● Select your new map in the Projects view, and right click to choose Rename.

● Enter the name Natural Earth and press OK.

● Close the map previously used Map clicking on the X near the name in the Map view.

Note!
You  can  open  and  close  the  maps  whenever  you  want,  the  information  will  be  
automatically saved by udig. To open an existing map double clik on the name of the  
map in the Project view.

● In the Layer menu, select Add

● Choose Files from the provided list and press Next.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Select the files NE1_50M_SR_W.tif from your data directory:

● Press Open and the raster layer will be added to your map

● Search the layer 10m admin 0 countries in the Catalog and add it to the new active map as 
explained in the previous paragraphs, the layers will  the added over the raster image and 
rendered with a default style.

○ The default style for the 10m admin 0 countries layer is slightly transparent so can see the 
base raster layer.

○ You may wish to zoom in and out using the toolbar Zoom Extent, Zoom In and Zoom Out 
commands.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Select and right click on the countries layer in the  Layers view and select  Change Style to 
open the Style Editor.

● The Style Editor is arranged into a series of pages.

● Select the Polygons page from the list on the right: we will use this page to add labels to the 
countries layer.

● Click the Labels tab on the Polygon page.

○ Enable labels by checking the enable/disable labelling checkbox

○ In the list to the far right of label choose the NAME attribute

This tutorial is written by UniTN, please refer to the authors for any question.
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● You can press the Apply and/or OK button to see what your map will look like with labels.

7.1   Theme
A common use for maps is as a visual display of attribute values. In cartographic terms this is known 
as creating a Thematic map, accomplished by defining a theme for a layer.

The Style Editor is used to theme data by setting up a thematic style for a layer based on attribute 
values.

● Please reopen the Style Editor, switch to the Theme page and select the following:

● Attribute: Select the POP_EST attribute.

● Select 7 Classes instead of the proposed 5.

● Normalize: Select the GDP_MD_EST attribute.

● Filter the available color palettes to show a subset of those available:

This tutorial is written by UniTN, please refer to the authors for any question.
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○ Show: change from guilabel: Show All to Sequential, this option shows palettes which are 
a ramp of color.

○ Select the light orange to dark red color palette

● Press the OK button

● The countries  layer  is  now displayed  as  theme  of  population  data  normalized  by  gross  
domestic product as a quick measure of population productivity.

7.2   Legend
You can use a legend to review the colors and symbology used to illustrate your thematic map.

● From the menubar select Layer --> Legend.

This tutorial is written by UniTN, please refer to the authors for any question.



uDig Tutorial p. 27

● The Legend decorator offers a quick summary of your themed data.

● If you want to visualize the legend better you can uncheck the layer NE1_50M_SR_W from 
the Layers view.

● Zoom to the entire extent of the  10m admin 0 countries selecting the  Zoom to layer upper 
rigth of the Layer view.

7.3   Layout and Perspectives
● Map editors can be resized and expanded

○ Double click on the Natural Earth editor tab to maximize the editor display.

○ Use the zoom tool to explore the world while the editor is maximized.

This tutorial is written by UniTN, please refer to the authors for any question.
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○ Your Layers view is still available as a fast view on the left hand side of the screen. Press 
Layer view button to slide the layer view on and off the screen as needed. 

○ Double click on the Natural Earth editor tab again to restore the previous size.

● You can also open two map editors and arrange them side by side by dragging the Map editor 
tab into new position.

● You have a lot of flexibility in arranging views around your Map editor.

○ You can drag views into different locations along the edge of your map by dragging their 
View tab into the desired location.

○ You can detach a view by dragging it completely out of the window

○ You can right click on the view for more options including a slide out Fast view.

○ More views are available using the menubar Window --> Show Views

● The arrangement of the Workbench editors and views is called a Perspective.

○ Switch between perspectives using the menubar Window --> Open Perspective

○ Use the menubar  Window --> Reset Perspective to restore any views you accidentally 
closed during experimentation.

● Close the Map view clicking on the X near the name of the map on the upper side of the view.

8   Information Request
In this section, you will learn how to use the Info tool.

● Open your Natural Earth map,

This tutorial is written by UniTN, please refer to the authors for any question.
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Hint!

You can also double click on the Natural Earth map in the Projects view to open it.

● Uncheck or delete the  Legend layer in the  Layers view to have more space for displaying 
features.

● Use the Zoom tool to navigate to an interesting detail.

● Change to the Info tool in the Map editor Palette.

Hint!

You can use the i keyboard shortcut cycle between available information tools. The  
tool cursor will indicate the current tool so you do not have to look up when working.

● Use the  Info tool  to click  on a country:  the  Information view open to  list  each layer  with 
information

● The left pane of the Information is used to pick the details to display: pick the 10m admin 0 
countries feature.

● The right pane of the  Information view is used to explore the attributes of the country you 
clicked on.

● You will see the information view flash the country to remind you of the area  
you clicked. This is useful when sorting through several features on different 
layers.

● The  Information view is only used  to  review values, we will  cover editing 
further in this tutorial

This tutorial is written by UniTN, please refer to the authors for any question.
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● The details displayed based on the content picked in the left pane of the  Information view: 
Pick the NE1_50M_SR_W raster layer to review the RGB values.

● Exit the Info tool clicking on an other map navigation tool (zoom, pan or select).

9   Re-projection
The shapes making up a map can come from a range of coordinate reference systems - each using 
different measurements to record locations on the earth.

In order to combine these data sets on screen automatic reprojection is used to transform information  
into the common coordinate reference system you have selected for your map.

● You can ask that the map change its projection to match a layer.

Check the NE1_50M_SR_W layer in the Layers view to visualize the raster data, right click on 
NE1_50M_SR_W and use  Operation --> Set Map Projection from Layers to use this layers 
projection in the map.

○ Not all coordinate reference systems can display all information. Some are only valid for a  
specific region.

○ This operation can be useful if you are having any trouble displaying a layer and want to 
directly view the data.

Note!
You can see the CRS (Coordiate Reference System) of the  Map in the box in the  
lower right of the view map editor status area.

● You can also choose the map coordinate reference system yourself.

In  the  Map editor  status  area  press  the  WGS_1984 button  to  bring  up  the  Coordinate 
Systems property page for your map.

This tutorial is written by UniTN, please refer to the authors for any question.
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● The  Coordinate  Systems property  page allows  you  to  change the  Coordinate  Reference 
System of your map. The Standard CRS tab allows you to search the predefined coordinate 
reference systems.

Please type in wgs 84 / utm, then select zone 37N and press ENTER.

● This selects the UTM coordinate reference system based on 1984 datum which is commonly 
used to represent metric information, in the 37 zone northern hemisphere.

○ You can also search by name, try typing in 32637 (EPSG code) to list matching projection

● You can have a look at the formal definition of WGS 84 / UTM zone 37N by switching to the 
Custom CRS tab.

○ The definition is provided in  Well Known Text - you can use this format for your own 
custom CRS.

● Press the OK button to change the coordinate reference system of your map.

10   Creating Feature Type
In  this section we are going to  create  a new feature type to experiment with  some of  the more  
interesting edit tools.

● Close the Map Natural Earth

This tutorial is written by UniTN, please refer to the authors for any question.
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● Create a New Map

● Rename the map to Ex2

● Add the 10m_rivers_lake_centerlines.shp contained in your data folder. You can drag and 
drop the file onto the map, or use Layer --> Add from the menu bar (see previous chapters).

● Use the navigation tools to go and zoom to an interesting place in the world.

● Select the Layer --> Create command from the menu bar.

● Replace New_Feature_Type with Lake.

● Change the type of the the_geom attribute to MultiPolygon.

● Click Add Attribute button.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Select your new attribute and change the Type to Integer and the Name to type.

● Press OK button.

● Your layer has been added to the current map.

● Your data has been added to the Scratch area of the catalog.

11   Copying Content
Now that we have created a new feature type, we can use cut and paste to grab geometry content 
from other layers.

● Add the layer 10m_lakes to the map, it should be already loaded in the Catalog view.

● Select the layer  10m_lakes in the  Layers view and  Navigation --> Zoom to All in the menu 
bar, then zoom with Zoom window tool to Africa.

● In the Layers view make sure that 10m_lakes is selected as shown below.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Select Box Selection from the tool palette.

● Use the Box Selection tool to draw a box around the lakes of Africa. The lakes will change 
color when selected.

● Select Edit --> Copy from Edit menu. These lakes will be placed onto the clipboard.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Select Lake layer in the layer view, and select Edit --> Paste from Edit menu. You can do the 
same operation with right-click mouse button in the map view and select Paste.

● Press Save button to save the new layer and write these new features into it.

● Select the folder where to save the new shapefile called Lake and then press Finish.

While saving it is possible to change both the name and the CRS of the shapefile you are 
saving.

12   Create Geometry
The second category of tools involves creating geometry, we will cover line and polygon creation and 
vertex snapping.

● Select 10m_rivers_lake_centerlines in the layer view and zoom to Ethiopia.

● Choose the Create Line Tool from the Create drawer of the Palette.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Draw a river on your map, and press Enter on the keyboard to indicate that you are finished 
your line.

● You have just created a new river, remember to press Save or Commit in the tool bar to write 
your change to the shape file.

● Change to the Lake layer in the Layers view.

● Choose the Create Polygon Tool from the Create drawer of the Palette.

● Enable snapping by pressing  CTRL +  SHIFT +  S until Snap to features in current layer is 
displayed in a dialog.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Draw a polygon, close to a feature, as you draw close to another polygon or a line you can 
watch how snapping effects the drawing process.

● You can complete your polygon by ending it on the vertex that started the polygon or pressing  
Enter on the keyboard when you want to connect the last inserted vertex with the first one.

● Please press Save or Commit button in the toolbar to save the new feature in the shapefile.

This tutorial is written by UniTN, please refer to the authors for any question.
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13   Changing Snapping Behavior
The snapping choices included with uDig are as follows:

No Snapping Snapping is turned off by default.

Selected Features Snap to a vertex in a selected feature.

Current Layer Snap to a vertex in the current layer

All Layers Snap to a vertex in any layer

Grid Snap to the nearest grid intersection

There are three different ways to change the snap behavior:

● In the which can be found in the Window --> Preferences menu.

● While an edit tool is  active press  CTRL +  SHIFT +  S. This will cycle through the available 
snap behaviors. A small pop-up will display the new behavior.

● You can see a short cut of the tool snapping options in the tool options along the bottom of  
the Map view.

14   Delete Feature Tool
● To delete the feature just created select the Delete Feature Tool in the Feature Editing tool of 

palette.

This tutorial is written by UniTN, please refer to the authors for any question.
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● Click on the newly created feature and it will be deleted.

15   Working with Attributes
In this section you will learn how to edit an Attribute, along the way we will explore the use of search 
and selection tools.

To  start  out  with,  lets  import  in  the  Catalog and  visualize  in  the  Map the  layer 
10m_populated_place_simple, then:

● select Navigation --> Zoom to All from the menu bar

● select the layers 10m_lake, lake and 10m_rivers_lake_centerlines in the Layers view

Note!
On windows hold down the control key or shift key for selecting multiple files.

● select the Edit --> Delete command from the menu bar to delete them from visualization so 
you will have only the layer 10m_populated_place_simple in the Layers view

This tutorial is written by UniTN, please refer to the authors for any question.
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● ensure that 10m_populated_place_simple is still selected in the layers view, and select the 
Table view

● the first time you use Table view you will need to accept a warning that all the features will be 
loaded into memory, check the flag on Do not show the warning in the future

● the Table view shows all the features for the current layer

This tutorial is written by UniTN, please refer to the authors for any question.
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● choose the Box Selection tool in the Palette --> Selection

● if  you select one feature in the  Table view you will  see that the corresponding line will  be 
highlighted in yellow in the table and also in the Map view

This tutorial is written by UniTN, please refer to the authors for any question.
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● if you select one or more feature in the Map view you will see that/those features highlighted 
in yellow in the map and also the relative rows in the Table view

● it is possible that you will not see all the highlighted features in the Table view, as you can see 
in the following image, three features are selected from the Map view and you can see only 2 
features highlighted in  the  Table,  even if  in  the header there is  written that  the selected 
features are 3

This tutorial is written by UniTN, please refer to the authors for any question.
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● select the Promote selection to top of the table from the Table view

● visualize the 10m_admin_0_countries in the map and zoom to Ethiopia: you can navigate the 
map and then select the country and verify that it is Ethiopia

Note!
The selection tool works only on the layer selected in the Layer view.

This tutorial is written by UniTN, please refer to the authors for any question.
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Note!
To unselect the feature just select something else or nothing in the Map view.

● select the 10m_populated_places_simple in the Layers view and select in the Map view the 
cities until you find Arba Minch

● you can also look for a specific attribute with the search too in the Table view, type Addis in 
the box and press Enter on the keyboard: as you can see there are different features having 
the word Addis in one of the attributes field, in this case most in the ADM1NAME

This tutorial is written by UniTN, please refer to the authors for any question.
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● if you want to select only the city of Addis Ababa you have to select the name of the attribute 
in which searching for that word: select  NAME from the drop down menu and press  Enter, 
you will see the city highlighted both in the Table and in the Map view.

● go ahead, search Arba Minch and rename the city yourself, change the NAME attribute by 
clicking in the Table view inside the cell you want to edit

This tutorial is written by UniTN, please refer to the authors for any question.
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● once selected the cell to edit type the new NAME as My City and then press Enter on the 
keyboard

Note!
Not all aspects of a feature are editable: bounds are derived from the geometry, and  
ID is uDig's internal  id handling and not meant to be always the same (if  a new  
feature is added or deleted the ids could change).

● press the Commit Changes or Save button, in the tool bar, to save the modified layer

This tutorial is written by UniTN, please refer to the authors for any question.
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Note!
Take care, uDig allows to edit the attribute table at any time without having to specify  
other  things.  If  you do not  want to save the changes in  the attribute  table press  
Rollback button in the tool bar before saving anything.

16   Editing Geometry in a shapefile
We will use the Edit Geometry tool to move river Genale in Ethiopia.

● Add the layer 10m_rivers_lake_centerlines to your Map from the Catalog.

● Select 10m_rivers_lake_centerlines in the Layers view.

● Zoom to Ethiopia and look for River  Genale in the southern part of the country. Zoom to a 
scale of 1:1000000 and pan until the map contains the starting point of that river.

This tutorial is written by UniTN, please refer to the authors for any question.



uDig Tutorial p. 48

● Change to the Edit Geometry tool from the tool palette (click the Editing drawer to see the 
available editing tools).

● Use the Edit Geometry tool to select river Genale.

● The river will change color and develop “vertex handles”.

● Move the vertex handles as you prefer one by one or selecting multiple vertex and moving all 
together.

This tutorial is written by UniTN, please refer to the authors for any question.
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Note!
Take care of not self intersecting the features while moving the vertex around.

● Add new vertex by switching to the Add Vertex tool in the Editing drawer of the Palette.

● You can click any where on the road to add a new vertex.

● While editing a feature you can use Undo and Redo in the Edit menu as required.

● Press the Commit Changes button in the tool bar to send your changes off to the shapefile.

● Your line has now been moved.

● You can edit many Features at once, from different layers, or from different sources of data.  
Pressing Commit Changes will send off all the changes made in the current map.

Note!
Commit will save the data in the file, uDig does not have automatic saving, to avoid  
any loose of the changes, please commit the changes more frequently.

This tutorial is written by UniTN, please refer to the authors for any question.
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17   Exporting to Shape file
In addition to editing content from many sources, you can also export content to a shapefile.

● Select  in  the  layer  10m_populated_places_simple only  the  cities  of  Ethiopia,  use  the 
Search tool in the Table view.

● With 10m_populated_places_simple selected, choose File --> Export from the menu bar or 
right click on the name of the layer in the Layers view and select Export.

● Open the Other option, select the Layer to Shapefile option and press Next

This tutorial is written by UniTN, please refer to the authors for any question.
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● Your  Ethiopian  cities  layer  will  be  available  for  export,  you  can  see  that  it  is  in  the  
CGS_WGS_1984 projection. uDig propose to save the new shapefile in the same directory of  
the  source  data  and  with  the  same  name,  click  on  the  name  and  write 
10m_ethiopian_populated_places

Hint!

The projection for your data is listed to the right. Click on this value to transform your  
data into a different projection.

● Press Finish to save the file to disk.

● Exported files are added to the catalog.

This tutorial is written by UniTN, please refer to the authors for any question.
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18   Print
To print the current map you must first create a Page that allows you to lay it out and print it from 
there.

1. Open the map you wish to print: in this case we want to print the current opened map Ex2

2. Press the print button on the toolbar to create the printing page (or select File --> Print) 

3. It will ask you what template you wish to create the page from.

4. Page Editor will be opened showing the arrangement of the Page

5. You can modify some of the component of the print by selecting them and modifying the 
dimension and position, or choosing new elements to add from the Palette 

6. You can  now press  the pdf  button to generate a PDF in the desired path.

19   Import GPS data
Point information can be easily written in an ASCII file with the format of Comma Separated Values 
(CSV), this means an  ascii editable file with information separated by a special symbol, typically a 
comma.

GPS collected point information in the field are saved in this native format on the GPS and it can be 
directly imported in uDig. In particular Leica GPS saves the registered points with some attributes as a 

This tutorial is written by UniTN, please refer to the authors for any question.
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CSV file containing the following columns:

Attribute Description Type
long longitude of the point in degree X

lat latitude of the point in degree Y

elev elevation of the point double

IDpoint unique identifier of the registered point string

PDOP precision of the GPS signal for the current point double

desc a short description of the point if available string

user an identifier of the person that collected the point in the field string

yymmdd date of the relief as year (YY), month (MM) and day (DD) string

hhmm timestep of the measure in hours (hh) and minutes (mm) string

The file looks like a TXT file with columns separated by a comma:

and the meaning of these information is what is contained in the previous table in the form of:

long,lat,elev,IDpoint,PDOP,descrition,user,yymmdd,hh:mm

Note!
The GPS collected data are in lat/long WGS84 CRS (Coordinate Reference System)  
this is the standard CRS identified by EPSG code 4326.

You can import this file directly in uDig and create a point layer, to do this follow the following points:

● open the Map in which you want to import the data or close all the maps to create a new one

● switch to the Catalog view and press the Import button on the upper right side of the window 
then select the CSV Import to import a file in CSV (or TXT) format from the local file system 
into the workspace, then press Next

This tutorial is written by UniTN, please refer to the authors for any question.
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Note!
You must open the original file exported by the GPS and check for the first line. If  
there is an header as first line, please remove it from the file, save and select this  
new version of the file for the import.

● in the next window select the file on the file system and enter the required information:

● CRS (Coordinate Reference System) of the original point data: please select 
to insert the CRS and type 4326 in the text box

● separator character: leave the proposed default value comma

● complete the table by selecting the name of the attributes and their type: the 
values contained in the table are those of the first row of the original file.  
Select che attribute name to change as Fieldname and open the drop down 
menu in the Type column to change the proposed ones

This tutorial is written by UniTN, please refer to the authors for any question.
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● the complete selection of attributes and types are proposed in the following 
picture, press Next to go on and create the new point layer

Note!
Latitude and Longitude attributes are taken to create the geometry of the points: do  
not  change  the  proposed  attribute  types,  they  have  to  be  X (longitude)  and  Y 
(latitude).

● if you had an opened map, a temporary layer is added to your active map, otherwise a new 
map is created with the name of the temporary layer and only this layer is preset

This tutorial is written by UniTN, please refer to the authors for any question.
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● as you can see the new layer has a red asterisk before the name in the  Layers view, this 
means that it is a temporary layer

● if you want to save the new layer as shapefile you have to press Save button in the toolbar or 
File --> Save from the menu and select the path, the name and the projection of the new 
shapefile. Press Finish to save the file

Note!
Since the field relief operations will be a lot of data, we suggest you to choose a good  
identifier  for  the  relief  as  name  of  the  new  shapefile,  for  example  something  
containing  the  Zone,  the  user and  the  date of  the  relief,  all  separated  by  an 
underscore. An example could be zoneA_user_2013_05_21.

● as you can see the layer's  name is  changed in  the  Layers view and the red asterisk is 
disappeared, this means that the layer is saved on your hard disk.

● Your map has been updated to use your new layer, you can verify this by right clicking on  
your layer in the Layers view and checking its Properties

● select Summary from the left window and read the information contained about the path of 
the shapefile and the Feature Type for the list of attributes and types.

This tutorial is written by UniTN, please refer to the authors for any question.
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Note!
Your GPS always saves the data in this format, you have to repeat this procedure  
every time you will  receive data from field relief. Please save in different folders the  
original data (CSV or TXT) and the derived shapefiles.

This tutorial is written by UniTN, please refer to the authors for any question.
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